CVE-2026-44787
High
Description
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, the signup flow could allow newly registered users to set primary_group_id and gain whisper-group privileges without legitimate group membership on sites with whispers_allowed_groups configured. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
SeverityHigh
CVSS8.2
Exploit probability—
Product
Discourse
PublishedJul 9, 2026
First seenJul 9, 2026
Weakness typeCWE-269Improper privilege management
How to fix
Update
- discourse discourse2026.1.5, 2026.4.2, 2026.5.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| discourse discourse | 2026.1.0 ≤ v < 2026.1.5, 2026.4.0 ≤ v < 2026.4.2, 2026.5.0 ≤ v < 2026.5.1, 2026.6.0 | 2026.1.5, 2026.4.2, 2026.5.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.