CVE-2026-44914
Description
Apache NiFi 1.12.0 through 2.9.0 are missing authorization when replacing Process Groups that include extension components with specific Required Permissions based on the Restricted annotation. The Restricted annotation indicates additional privileges required, but framework authorization did not check restricted status when handling requests to replace Process Groups. The missing authorization permits a user with general write access to add components with Restricted status. Apache NiFi installations that do not implement specific authorization for Restricted components are not subject to this vulnerability because the framework enforces write permissions as the security boundary. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation, which removes the implementation of Restricted status authorization from the framework.
How to fix
- apache nifi2.10.0 or later
- org.apache.nifi:nifi-web-api2.9.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache nifi | 1.12.0 ≤ v < 2.10.0 | 2.10.0 |
| org.apache.nifi:nifi-web-apiMaven | 1.12.0 ≤ v < 2.9.0 | 2.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.