CVE-2026-44930
Critical
Description
An LDAP injection vulnerability in the LDAP Certificate repository of the XKMS server in Apache CXF may allow an attacker to retrieve arbitrary certificates from the repository. Users are recommended to upgrade to versions 4.2.1, 4.1.6 or 3.6.11, which fix this issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Cxf
PublishedMay 22, 2026
First seenMay 22, 2026
Weakness typeCWE-90CWE-90
How to fix
Update
- apache cxf3.6.11, 4.1.6 or later
- org.apache.cxf.services.xkms:cxf-services-xkms-x509-repo-ldap4.2.1, 4.1.6, 3.6.11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cxf | v < 3.6.11, 4.0.0 ≤ v < 4.1.6, 4.2.0 | 3.6.11, 4.1.6 |
| org.apache.cxf.services.xkms:cxf-services-xkms-x509-repo-ldapMaven | 4.2.0 ≤ v < 4.2.1, 4.1.0 ≤ v < 4.1.6, v < 3.6.11 | 4.2.1, 4.1.6, 3.6.11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.