CVE-2026-45109
High
Description
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
SeverityHigh
CVSS7.5
Exploit probability58. percentile0.9%
Product
Vercel Next.js
PublishedMay 13, 2026
First seenMay 13, 2026
Weakness typeCWE-288CWE-288
How to fix
Update
- vercel next.js15.5.18, 16.2.6 or later
- next15.5.18, 16.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 15.2.0 ≤ v < 15.5.18, 16.0.0 ≤ v < 16.2.6 | 15.5.18, 16.2.6 |
| nextnpm | 15.2.0 ≤ v < 15.5.18, 16.0.0 ≤ v < 16.2.6 | 15.5.18, 16.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.