CVE-2026-45133
Description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.
How to fix
- sensiolabs symfony5.4.52, 6.4.40, 7.4.12, 8.0.12 or later
- symfony/yaml5.4.52, 6.4.40, 7.4.12, 8.0.12 or later
- symfony/symfony5.4.52, 6.4.40, 7.4.12, 8.0.12 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| sensiolabs symfony | v < 5.4.52, 6.0.0 ≤ v < 6.4.40, 7.0.0 ≤ v < 7.4.12, 8.0.0 ≤ v < 8.0.12 | 5.4.52, 6.4.40, 7.4.12, 8.0.12 |
| symfony/yamlPackagist | v < 5.4.52, 6.0.0 ≤ v < 6.4.40, 7.0.0 ≤ v < 7.4.12, 8.0.0 ≤ v < 8.0.12 | 5.4.52, 6.4.40, 7.4.12, 8.0.12 |
| symfony/symfonyPackagist | v < 5.4.52, 6.0.0 ≤ v < 6.4.40, 7.0.0 ≤ v < 7.4.12, 8.0.0 ≤ v < 8.0.12 | 5.4.52, 6.4.40, 7.4.12, 8.0.12 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.