CVE-2026-45158

Critical

Description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, unsanitized user input is passed to the DHCP configuration of the configured interface, which is processed by a shell script, allowing remote code execution as root on the underlying operating system. This vulnerability is fixed in 26.1.8.

SeverityCritical
CVSS9.1
Exploit probability—
ProductOpnsense
PublishedMay 13, 2026
First seenMay 13, 2026
Weakness typeCWE-88CWE-88

How to fix

Update
  • opnsense opnsense26.1.8 or later

Affected products

ProductAffected versionsFixed in
opnsense opnsensev < 26.1.826.1.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-45158 · Opnsense · Dark Radar