CVE-2026-45281
Description
Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, with the knowledge of other users’ principal URL an attacker could possibly send a request to gain full access to their calendar. Therefore, the attacker must be an authenticated user. This is because of improper authorization controls in the backend of the calendar. If the attacker had access to the calendar, they would be able to view and modify it. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9, 29.0.16.16, 28.0.14.17, 27.1.11.26, 26.0.13.26, 25.0.13.29, 24.0.12.34, 23.0.12.35, 22.2.10.39, or 21.0.9.23
How to fix
- nextcloud nextcloud_server32.0.9, 33.0.3, 21.0.9.23, 22.2.10.39, 23.0.12.35, 24.0.12.34, 25.0.13.29, 26.0.13.26, 27.1.11.26, 28.0.14.17, 29.0.16.16, 30.0.17.9, 31.0.14.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | 32.0.0 ≤ v < 32.0.9, 33.0.0 ≤ v < 33.0.3, 21.0.0 ≤ v < 21.0.9.23, 22.0.0 ≤ v < 22.2.10.39, 23.0.0 ≤ v < 23.0.12.35, 24.0.0 ≤ v < 24.0.12.34, 25.0.0 ≤ v < 25.0.13.29, 26.0.0 ≤ v < 26.0.13.26, 27.0.0 ≤ v < 27.1.11.26, 28.0.0 ≤ v < 28.0.14.17, 29.0.0 ≤ v < 29.0.16.16, 30.0.0 ≤ v < 30.0.17.9, 31.0.0 ≤ v < 31.0.14.5 | 32.0.9, 33.0.3, 21.0.9.23, 22.2.10.39, 23.0.12.35, 24.0.12.34, 25.0.13.29, 26.0.13.26, 27.1.11.26, 28.0.14.17, 29.0.16.16, 30.0.17.9, 31.0.14.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.