CVE-2026-45505

High

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. Non-parenthesized discovery wrappers such as `masterslave:vm://...,...` and `static:vm://...` incorrectly pass validation allowing bypass of fix in CVE-2026-34197.  Original description from CVE-2026-34197. Apache ActiveMQ exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery UR that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Activemq
PublishedJun 1, 2026
First seenJun 1, 2026

How to fix

Update
  • apache activemq5.19.7, 6.2.6 or later
  • apache activemq_broker5.19.7, 6.2.6 or later
  • org.apache.activemq:activemq-broker5.19.7, 6.2.6 or later
  • org.apache.activemq:activemq-all5.19.7, 6.2.6 or later
  • org.apache.activemq:apache-activemq5.19.7, 6.2.6 or later

Affected products

ProductAffected versionsFixed in
apache activemqv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6
apache activemq_brokerv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6
org.apache.activemq:activemq-brokerMavenv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6
org.apache.activemq:activemq-allMavenv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6
org.apache.activemq:apache-activemqMavenv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.