CVE-2026-45690
Description
Nextcloud is an open source content collaboration platform. In Nextcloud Server from versions 32.0.0 to before 32.0.9, and 33.0.0 to before 33.0.3, an authentication bypass vulnerability allowed attackers with knowledge of a user's password to circumvent two-factor authentication (2FA) protections. When a user initiated login with valid credentials on a 2FA-enabled account, the system created a temporary session token before enforcing the second factor challenge. This token could be extracted and replayed via HTTP Basic Authentication to gain unauthorized access to authenticated endpoints. It is recommended that the Nextcloud Server is upgraded to 33.0.3 or 32.0.9. It is recommended that the Nextcloud Enterprise Server is upgraded to 33.0.3, 32.0.9, 31.0.14.5, 30.0.17.9 or 29.0.16.16
How to fix
- nextcloud nextcloud_server32.0.9, 33.0.3, 29.0.16.16, 30.0.17.9, 31.0.14.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_server | 32.0.0 ≤ v < 32.0.9, 33.0.0 ≤ v < 33.0.3, 29.0.0 ≤ v < 29.0.16.16, 30.0.0 ≤ v < 30.0.17.9, 31.0.0 ≤ v < 31.0.14.5 | 32.0.9, 33.0.3, 29.0.16.16, 30.0.17.9, 31.0.14.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.