CVE-2026-45692
Description
Caddy is an extensible server platform that uses TLS by default. From 2.4.0 until 2.11.3, the authorization layer and the /config traversal layer do not agree on what object the path refers to. In this case, a path authorized for one config object is accepted, but then resolves to a different config object during traversal. This happens because the authorization layer uses string prefix matching and the /config traversal layer parses array indices numerically using strconv.Atoi(). This vulnerability is fixed in 2.11.3.
How to fix
- caddyserver caddy2.11.3 or later
- github.com/caddyserver/caddy/v22.11.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| caddyserver caddy | 2.4.0 ≤ v < 2.11.3 | 2.11.3 |
| github.com/caddyserver/caddy/v2Go | 2.4.0 ≤ v < 2.11.3 | 2.11.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.