CVE-2026-45694

Medium

Description

LibreNMS is a network monitoring system. In versions up to and including 26.4.0, the Proxmox application view is vulnerable to reflected cross-site scripting through the user-supplied instance and vmid GET parameters, which are reflected into the page title without adequate encoding. The parameters are placed into the page title with only strip_tags applied, and the title is then written into an inline document.title assignment through string interpolation, so a single quote terminates the JavaScript string and the remaining input runs as script. An attacker who lures an authenticated user into following a crafted link can execute script in that user's session, enabling actions such as theft of session data. This issue is fixed in version 26.5.0.

SeverityMedium
CVSS5.4
Exploit probability—
ProductLibrenms/librenms
PublishedAug 26, 2026
First seenAug 26, 2026

How to fix

Update
  • librenms/librenms26.5.0 or later

Affected products

ProductAffected versionsFixed in
librenms/librenmsPackagistv < 26.5.026.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.