CVE-2026-45718

Medium

Description

Budibase is an open-source low-code platform. Prior to 3.38.1, the row action trigger endpoint (POST /api/tables/:sourceId/actions/:actionId/trigger) fails to validate that the user-supplied rowId is within the scope of the view's row filters. A user with access to a filtered view can trigger row actions on any row in the underlying table, including rows explicitly excluded by the view's security filters. This vulnerability is fixed in 3.38.1.

SeverityMedium
CVSS5.4
Exploit probability—
ProductBudibase
PublishedMay 27, 2026
First seenMay 27, 2026

How to fix

Update
  • budibase3.38.1 or later

Affected products

ProductAffected versionsFixed in
budibasenpmv < 3.38.13.38.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.