CVE-2026-45760

High

Description

(Externally Controlled Reference to a Resource in Another Sphere), (Authorization Bypass Through User-Controlled Key) vulnerability in Apache Camel K. Authorized users in a Kubernetes namespace can create a Build resource, controlling the Pod generation in a namespace of their choice, including the operator namespace. This issue affects Apache Camel K: from 2.0.0 before 2.8.1, from 2.9.0 before 2.9.2, from 2.10.0 before 2.10.1. Users are recommended to upgrade to version 2.10.1 (or 2.8.1 or 2.9.2), which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductGithub.com/apache/camel-k/v2
PublishedMay 21, 2026
First seenMay 21, 2026

How to fix

Update
  • github.com/apache/camel-k/v22.8.1, 2.9.2, 2.10.1 or later

Affected products

ProductAffected versionsFixed in
github.com/apache/camel-k/v2Gov < 2.8.1, 2.9.0 ≤ v < 2.9.2, 2.10.0 ≤ v < 2.10.12.8.1, 2.9.2, 2.10.1
github.com/apache/camel-kGoNo range specified—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.