CVE-2026-45772
Description
Turborepo is a high-performance build system for JavaScript and TypeScript codebases. From 1.1.0 to before 2.9.14, Turborepo can be vulnerable to arbitrary code execution when run in untrusted repositories that contain malicious Yarn configuration. In affected versions, package manager detection executed yarn --version from the project directory, which could cause Yarn to load and execute a project-controlled yarnPath from .yarnrc.yml. An attacker who controls repository contents could cause code execution when a user or CI system runs affected turbo, @turbo/codemod, or @turbo/workspace conversion commands. This vulnerability is fixed in 2.9.14.
How to fix
- vercel turborepo2.9.14 or later
- turbo2.9.14 or later
- @turbo/codemod2.9.14 or later
- @turbo/workspaces2.9.14 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel turborepo | 1.1.0 ≤ v < 2.9.14 | 2.9.14 |
| turbonpm | 1.1.0 ≤ v < 2.9.14 | 2.9.14 |
| @turbo/codemodnpm | 2.3.4 ≤ v < 2.9.14 | 2.9.14 |
| @turbo/workspacesnpm | 2.3.4 ≤ v < 2.9.14 | 2.9.14 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.