CVE-2026-45793

High

Description

Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\IO\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and interpolates rejected tokens into an UnexpectedValueException; GitHub Actions GITHUB_TOKEN values using the ghs_<id>_<base64url-JWT> format can contain -, fail validation, and be disclosed to stderr or CI logs. This issue is fixed in versions 1.10.28, 2.2.28, and 2.9.8.

SeverityHigh
CVSS7.5
Exploit probability—
ProductComposer/composer
PublishedJul 15, 2026
First seenJul 15, 2026

How to fix

Update
  • composer/composer2.9.8, 2.2.28, 1.10.28 or later

Affected products

ProductAffected versionsFixed in
composer/composerPackagist2.3.0 ≤ v < 2.9.8, 2.0.0 ≤ v < 2.2.28, 1.0 ≤ v < 1.10.282.9.8, 2.2.28, 1.10.28

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-45793 · Composer/composer · Dark Radar