CVE-2026-45815

High

Description

Reachable Assertion vulnerability in Apache NimBLE. A specially crafted ATT Read Multiple Variable Response (BLE_ATT_OP_READ_MULT_VAR_RSP) may trigger assert in ATT parser. Severity is medium as this requires DUT to first send ATT Read Multiple Variable Request. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Nimble
PublishedJul 24, 2026
First seenJul 24, 2026
Weakness typeCWE-617CWE-617

How to fix

Affected products

ProductAffected versionsFixed in
apache nimblev < 1.10.01.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.