CVE-2026-4610

Medium

Description

The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pm_author_message' parameter in the pm_send_message_to_author function in all versions up to, and including, 5.9.9.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 5.9.8.5.

SeverityMedium
CVSS6.4
Exploit probability—
ProductProfileGrid – User Profiles, Groups and Communities
PublishedJun 23, 2026
First seenJun 23, 2026

How to fix

Sources list no fixed version or patch link for this vulnerability.

Affected products

ProductAffected versionsFixed in
metagauss ProfileGrid – User Profiles, Groups and Communitiesv ≤ 5.9.9.2—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-4610 · ProfileGrid – User Profiles, Groups and Communities · Dark Radar