CVE-2026-46339
Critical
Description
9Router is an AI router & token saver. From 0.4.30 until 0.4.37, 9Router's src/proxy.js middleware did not protect /api/cli-tools/* and /api/mcp/*, allowing unauthenticated registration of customPlugins through src/app/api/cli-tools/cowork-settings/route.js and command execution through the MCP bridge. This vulnerability is fixed in 0.4.37.
SeverityCritical
CVSS10.0
Exploit probability—
Product9router
PublishedJul 15, 2026
First seenJul 15, 2026
How to fix
Update
- 9router0.4.37 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| 9routernpm | 0.4.30 ≤ v < 0.4.37 | 0.4.37 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.