CVE-2026-46452
Medium
Description
Improper Input Validation vulnerability in Apache NimBLE in Mesh Proxy SAR reassembly could result in passing broken data toward application resulting in memory pressure and unstable parsing behavior. This issue affects Apache NimBLE: through 1.9.0. Users are recommended to upgrade to version 1.10.0, which fixes the issue.
SeverityMedium
CVSS5.3
Exploit probability60. percentile0.9%
Product
Apache Nimble
PublishedJul 24, 2026
First seenJul 24, 2026
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache nimble1.10.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache nimble | v < 1.10.0 | 1.10.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.