CVE-2026-46605

Medium

Description

Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Activemq
PublishedJun 1, 2026
First seenJun 1, 2026
Weakness typeCWE-285CWE-285

How to fix

Update
  • apache activemq5.19.7, 6.2.6 or later
  • apache activemq_broker5.19.7, 6.2.6 or later
  • org.apache.activemq:apache-activemq5.19.7, 6.2.6 or later

Affected products

ProductAffected versionsFixed in
apache activemqv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6
apache activemq_brokerv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6
org.apache.activemq:apache-activemqMavenv < 5.19.7, 6.0.0 ≤ v < 6.2.65.19.7, 6.2.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.