CVE-2026-46718

Medium

Description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Calcite
PublishedJun 2, 2026
First seenJun 2, 2026
Weakness typeCWE-470CWE-470

How to fix

Update
  • apache calcite1.42.0 or later
  • org.apache.calcite:calcite-core1.42.0 or later

Affected products

ProductAffected versionsFixed in
apache calcite1.5.0 ≤ v < 1.42.01.42.0
org.apache.calcite:calcite-coreMaven1.5.0 ≤ v < 1.42.01.42.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.