CVE-2026-47339

High

Description

Incorrect Authorization vulnerability in Apache APISIX. An attacker can capitalise on authz-casdoor plugin under default configuration to authenticate themselves with credentials from a different source. This issue affects Apache APISIX: from 2.14.1 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache Apisix
PublishedJun 19, 2026
First seenJun 19, 2026

How to fix

Update
  • apache apisix3.17.0 or later

Affected products

ProductAffected versionsFixed in
apache apisix2.14.1 ≤ v < 3.17.03.17.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.