CVE-2026-47737

High

Description

Puma is a Ruby/Rack web server built for parallelism. From 5.5.0 until 7.2.1 and 8.0.2, Puma is vulnerable to source IP spoofing when set_remote_address proxy_protocol: :v1 is enabled and persistent connections are used because Puma incorrectly re-parses PROXY protocol headers after each keep-alive request on the same connection, allowing an attacker to inject a second PROXY header and overwrite REMOTE_ADDR. This issue is fixed in versions 7.2.1 and 8.0.2.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPuma
PublishedJul 14, 2026
First seenJul 14, 2026

How to fix

Update
  • puma8.0.2, 7.2.1 or later

Affected products

ProductAffected versionsFixed in
pumaRubyGems8.0.0 ≤ v < 8.0.2, 5.5.0 ≤ v < 7.2.18.0.2, 7.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-47737 · Puma · Dark Radar