CVE-2026-47759
Description
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
How to fix
- tiny tinymce5.11.1, 7.9.3, 8.5.1 or later
- tinymce7.9.3, 8.5.1 or later
- TinyMCE7.9.3, 8.5.1 or later
- tinymce/tinymce7.9.3, 8.5.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| tiny tinymce | v < 5.11.1, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 5.11.1, 7.9.3, 8.5.1 |
| tinymcenpm | v ≤ 5.10.9, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 7.9.3, 8.5.1 |
| TinyMCENuGet | v ≤ 5.10.9, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 7.9.3, 8.5.1 |
| tinymce/tinymcePackagist | v ≤ 5.10.9, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 7.9.3, 8.5.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.