CVE-2026-47761
High
Description
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
SeverityHigh
CVSS8.7
Exploit probability—
Product
Tinymce
PublishedMay 28, 2026
First seenMay 28, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- tiny tinymce5.11.1, 7.9.3, 8.5.1 or later
- tinymce7.9.3, 8.5.1 or later
- TinyMCE7.9.3, 8.5.1 or later
- tinymce/tinymce7.9.3, 8.5.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| tiny tinymce | v < 5.11.1, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 5.11.1, 7.9.3, 8.5.1 |
| tinymcenpm | v ≤ 5.10.9, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 7.9.3, 8.5.1 |
| TinyMCENuGet | v ≤ 5.10.9, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 7.9.3, 8.5.1 |
| tinymce/tinymcePackagist | v ≤ 5.10.9, 6.0.0 ≤ v < 7.9.3, 8.0.0 ≤ v < 8.5.1 | 7.9.3, 8.5.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.