CVE-2026-47767

Critical

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 5.4.46 until 5.4.52, 6.4.40, 7.4.12, and 8.0.12, the CVE-2024-50340 fix gated runtime argv parsing on empty($_GET), but parse_str() and the web SAPI can disagree, allowing a crafted query string to leave $_GET empty while $_SERVER['argv'] still carries attacker-controlled --env or --no-debug flags that change APP_ENV or APP_DEBUG. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

SeverityCritical
CVSS9.8
Exploit probability—
ProductSensiolabs Symfony
PublishedJul 14, 2026
First seenJul 14, 2026
Weakness typeCWE-436CWE-436

How to fix

Update
  • sensiolabs symfony5.4.52, 6.4.40, 7.4.12, 8.0.12 or later
  • symfony/runtime5.4.52, 6.4.40, 7.4.12, 8.0.12 or later
  • symfony/symfony5.4.52, 6.4.40, 7.4.12, 8.0.12 or later

Affected products

ProductAffected versionsFixed in
sensiolabs symfony5.4.46 ≤ v < 5.4.52, 6.4.14 ≤ v < 6.4.40, 7.1.7 ≤ v < 7.4.12, 8.0.0 ≤ v < 8.0.125.4.52, 6.4.40, 7.4.12, 8.0.12
symfony/runtimePackagist5.4.46 ≤ v < 5.4.52, 6.4.14 ≤ v < 6.4.40, 7.1.7 ≤ v < 7.4.12, 8.0.0 ≤ v < 8.0.125.4.52, 6.4.40, 7.4.12, 8.0.12
symfony/symfonyPackagist5.4.46 ≤ v < 5.4.52, 6.4.14 ≤ v < 6.4.40, 7.1.7 ≤ v < 7.4.12, 8.0.0 ≤ v < 8.0.125.4.52, 6.4.40, 7.4.12, 8.0.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.