CVE-2026-48060

High

Description

Litestar is an Asynchronous Server Gateway Interface (ASGI) framework. Prior to version 2.20.0, Litestar instances which use a template engine in conjunction with CSRF protection are vulnerable to HTML Injection which can be escalated to Cross Site Scripting due to the contents of the CSRF cookie being excluded from automatic escaping by the template engine when configured inline with documentation recommendations. This issue has been patched in version 2.20.0.

SeverityHigh
CVSS8.1
Exploit probability—
ProductLitestar
PublishedJul 28, 2026
First seenJul 28, 2026

How to fix

Update
  • litestar2.22.0 or later

Affected products

ProductAffected versionsFixed in
litestarPyPIv < 2.22.02.22.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.