CVE-2026-48068
High
Description
@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.
SeverityHigh
CVSS7.5
Exploit probability—
Product@grpc/grpc-js
PublishedJul 14, 2026
First seenJul 14, 2026
Weakness typeCWE-248CWE-248
How to fix
Update
- @grpc/grpc-js1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, 1.14.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| @grpc/grpc-jsnpm | v < 1.9.16, 1.10.0 ≤ v < 1.10.12, 1.11.0 ≤ v < 1.11.4, 1.12.0 ≤ v < 1.12.7, 1.13.0 ≤ v < 1.13.5, 1.14.0 ≤ v < 1.14.4 | 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, 1.14.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.