CVE-2026-4810
Description
A Code Injection and Missing Authentication vulnerability in Google Agent Development Kit (ADK) versions 1.7.0 (and 2.0.0a1) through 1.28.1 (and 2.0.0a2) on Python (OSS), Cloud Run, and GKE allows an unauthenticated remote attacker to execute arbitrary code on the server hosting the ADK instance. This vulnerability was patched in versions 1.28.1 and 2.0.0a2. Customers need to redeploy the upgraded ADK to their production environments. In addition, if they are running ADK Web locally, they also need to upgrade their local instance.
How to fix
- google-adk1.28.1, 2.0.0a2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google-adkPyPI | 1.7.0 ≤ v < 1.28.1, 2.0.0a1 ≤ v < 2.0.0a2 | 1.28.1, 2.0.0a2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.