CVE-2026-48586

High

Description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Thrift
PublishedJul 27, 2026
First seenJul 27, 2026
Weakness typeCWE-409CWE-409

How to fix

Affected products

ProductAffected versionsFixed in
apache thriftv < 0.24.00.24.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-48586 · Apache Thrift · Dark Radar