CVE-2026-48717

Critical

Description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.

SeverityCritical
CVSS9.1
Exploit probability—
ProductOrg.openidentityplatform.openam:openam-oauth2
PublishedSep 15, 2026
First seenSep 15, 2026
Weakness typeCWE-285CWE-285

How to fix

Update
  • org.openidentityplatform.openam:openam-oauth216.1.1 or later

Affected products

ProductAffected versionsFixed in
org.openidentityplatform.openam:openam-oauth2Mavenv < 16.1.116.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.