CVE-2026-48779
Description
ws is an open source WebSocket client and server for Node.js. All versions from 1.1.0 up to (but not including) 5.2.5, from 6.0.0 up to 6.2.4, from 7.0.0 up to 7.5.11, and from 8.0.0 up to 8.21.0 are affected by a memory exhaustion DoS vulnerability. A peer can send a high volume of exceptionally small fragments and data chunks, with modest network traffic, to force the remote peer into allocating and holding structural wrappers that consume far more memory than the default documented message-size limit, leading to process termination due to OOM. This issue has been fixed in versions 5.2.5, 6.2.4, 7.5.11, and 8.21.0.
How to fix
- ws_project ws5.2.5, 6.2.4, 7.5.11, 8.21.0 or later
- ws5.2.5, 6.2.4, 7.5.11, 8.21.0 or later
- access.redhat.com/errata/RHSA-2026:48151
- access.redhat.com/errata/RHSA-2026:34342
- access.redhat.com/errata/RHSA-2026:57590
- access.redhat.com/errata/RHSA-2026:66545
- access.redhat.com/errata/RHSA-2026:66488
- access.redhat.com/errata/RHSA-2026:36754
- access.redhat.com/errata/RHSA-2026:33574
- access.redhat.com/errata/RHSA-2026:29197
- access.redhat.com/errata/RHSA-2026:41928
- access.redhat.com/errata/RHSA-2026:65126
- access.redhat.com/errata/RHSA-2026:60520
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| ws_project ws | 1.1.0 ≤ v < 5.2.5, 6.0.0 ≤ v < 6.2.4, 7.0.0 ≤ v < 7.5.11, 8.0.0 ≤ v < 8.21.0 | 5.2.5, 6.2.4, 7.5.11, 8.21.0 |
| wsnpm | 1.1.0 ≤ v < 5.2.5, 6.0.0 ≤ v < 6.2.4, 7.0.0 ≤ v < 7.5.11, 8.0.0 ≤ v < 8.21.0 | 5.2.5, 6.2.4, 7.5.11, 8.21.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.