CVE-2026-48910

Medium

Description

A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the markdown renderer, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This issue affects Apache JSPWiki: through 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Jspwiki
PublishedJul 30, 2026
First seenJul 30, 2026
Weakness typeCWE-80CWE-80

How to fix

Update
  • apache jspwiki2.12.4 or later

Affected products

ProductAffected versionsFixed in
apache jspwikiv < 2.12.42.12.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.