CVE-2026-49042

High

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Camel
PublishedJul 6, 2026
First seenJul 6, 2026

How to fix

Update
  • apache camel4.18.3, 4.21.0 or later
  • org.apache.camel:camel-langchain4j-tools4.18.3, 4.21.0 or later
  • org.apache.camel:camel-langchain4j-agent4.18.3, 4.21.0 or later
  • org.apache.camel:camel-spring-ai-tools4.18.3, 4.21.0 or later

Affected products

ProductAffected versionsFixed in
apache camel4.8.0 ≤ v < 4.18.3, 4.19.0 ≤ v < 4.21.04.18.3, 4.21.0
org.apache.camel:camel-langchain4j-toolsMaven4.8.0 ≤ v < 4.18.3, 4.19.0 ≤ v < 4.21.04.18.3, 4.21.0
org.apache.camel:camel-langchain4j-agentMaven4.8.0 ≤ v < 4.18.3, 4.19.0 ≤ v < 4.21.04.18.3, 4.21.0
org.apache.camel:camel-spring-ai-toolsMaven4.8.0 ≤ v < 4.18.3, 4.19.0 ≤ v < 4.21.04.18.3, 4.21.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.