CVE-2026-49230
Critical
Description
Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass. This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Apisix
PublishedJun 19, 2026
First seenJun 19, 2026
Weakness typeCWE-354CWE-354
How to fix
Update
- apache apisix3.17.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apisix | 3.8.0 ≤ v < 3.17.0 | 3.17.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.