CVE-2026-49231
Description
Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
How to fix
- apache apisix3.17.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apisix | 3.5.0 ≤ v < 3.17.0 | 3.17.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.