CVE-2026-49256

High

Description

Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, restricted tag and tag-group names attached to publicly readable categories as allowed_tags, allowed_tag_groups, or required tag groups could leak to anonymous and unauthorized users through category and group endpoints. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.

SeverityHigh
CVSS7.5
Exploit probability—
ProductDiscourse
PublishedJul 9, 2026
First seenJul 9, 2026

How to fix

Update
  • discourse discourse2026.1.5, 2026.4.2, 2026.5.1 or later

Affected products

ProductAffected versionsFixed in
discourse discourse2026.1.0 ≤ v < 2026.1.5, 2026.4.0 ≤ v < 2026.4.2, 2026.5.0 ≤ v < 2026.5.1, 2026.6.02026.1.5, 2026.4.2, 2026.5.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.