CVE-2026-49270
Description
Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
How to fix
- apache activemq5.19.7, 6.2.6 or later
- apache activemq_broker5.19.7, 6.2.6 or later
- org.apache.activemq:apache-activemq5.19.7, 6.2.6 or later
- org.apache.activemq:activemq-broker5.19.7, 6.2.6 or later
- org.apache.activemq:activemq-all5.19.7, 6.2.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache activemq | v < 5.19.7, 6.0.0 ≤ v < 6.2.6 | 5.19.7, 6.2.6 |
| apache activemq_broker | v < 5.19.7, 6.0.0 ≤ v < 6.2.6 | 5.19.7, 6.2.6 |
| org.apache.activemq:apache-activemqMaven | v < 5.19.7, 6.0.0 ≤ v < 6.2.6 | 5.19.7, 6.2.6 |
| org.apache.activemq:activemq-brokerMaven | v < 5.19.7, 6.0.0 ≤ v < 6.2.6 | 5.19.7, 6.2.6 |
| org.apache.activemq:activemq-allMaven | v < 5.19.7, 6.0.0 ≤ v < 6.2.6 | 5.19.7, 6.2.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.