CVE-2026-49364
Critical
Description
An unauthenticated network-adjacent attacker can leverage discovery to capture cluster administrative credentials during the initial cluster connection handshake. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes the issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Artemis
PublishedSep 10, 2026
First seenSep 10, 2026
Weakness typeCWE-306Missing authentication for critical function
How to fix
Update
- apache artemis2.44.0, 2.57.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache artemis | 1.0.0 ≤ v < 2.44.0, 2.50.0 ≤ v < 2.57.0 | 2.44.0, 2.57.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.