CVE-2026-49432
Description
Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
How to fix
- apache activemq5.19.8, 6.2.7 or later
- org.apache.activemq:apache-activemq5.19.8, 6.2.7 or later
- org.apache.activemq:activemq-all5.19.8, 6.2.7 or later
- org.apache.activemq:activemq-stomp5.19.8, 6.2.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache activemq | v < 5.19.8, 6.0.0 ≤ v < 6.2.7 | 5.19.8, 6.2.7 |
| org.apache.activemq:apache-activemqMaven | v < 5.19.8, 6.0.0 ≤ v < 6.2.7 | 5.19.8, 6.2.7 |
| org.apache.activemq:activemq-allMaven | v < 5.19.8, 6.0.0 ≤ v < 6.2.7 | 5.19.8, 6.2.7 |
| org.apache.activemq:activemq-stompMaven | v < 5.19.8, 6.0.0 ≤ v < 6.2.7 | 5.19.8, 6.2.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.