CVE-2026-49833
Description
DSpace open source software is a repository application which provides durable access to digital resources. From versions 8.0-rc1 to before 8.4, 9.0-rc1 to before 9.3, and 10-rc1 to before 10.0, a path traversal vulnerability is possible via the COAR Notify / LDN service in DSpace. The attacker MUST already have DSpace administrator credentials in order to perform the attack. When reading a file input stream of an "inbound pattern" / "template", used to generate an LDN message, the LDN class does not check for path traversal or restrict the templates to a known base path. This could allow an untrusted file from elsewhere in the file system (e.g. an export log, a bitstream path, a temporary file) to be read and interpreted as an Apache Velocity template. This issue has been patched in versions 8.4, 9.3, and 10.0.
How to fix
- org.dspace:dspace-api8.4, 9.3, 10.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| org.dspace:dspace-apiMaven | 8.0-rc1 ≤ v < 8.4, 9.0-rc1 ≤ v < 9.3, 10.0-rc1 ≤ v < 10.0 | 8.4, 9.3, 10.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.