CVE-2026-49872

High

Description

Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache Apisix
PublishedJun 19, 2026
First seenJun 19, 2026

How to fix

Update
  • apache apisix3.17.0 or later

Affected products

ProductAffected versionsFixed in
apache apisix3.0.0 ≤ v < 3.17.03.17.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.