CVE-2026-50127
Medium
Description
Weblate is a web based localization tool. From version 5.15 to before version 2026.6, Weblate's VCS_RESTRICT_PRIVATE did not properly account for some transitional IPv6 ranges, multicast addresses, or some semi-private IPv4 ranges, which allowed some addresses to bypass private range restrictions. This issue has been patched in version 2026.6.
SeverityMedium
CVSS5.9
Exploit probability—
Product
Weblate
PublishedJun 10, 2026
First seenJun 10, 2026
Weakness typeCWE-918Server-side request forgery (SSRF)
How to fix
Update
- weblate2026.6 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| weblatePyPI | 5.15 ≤ v < 2026.6 | 2026.6 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.