CVE-2026-50147
Description
Metabase is an open-source business intelligence and embedded analytics tool. From 1.57.0 until 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4, an attacker who can configure a Metabase database connection can read arbitrary files from the Metabase server's filesystem by adding unsafe JDBC parameters to a MySQL or MariaDB connection, causing the driver to read files from the Metabase host and expose the contents through queries against the connected database or through validation error messages. This issue is fixed in versions 1.57.19.1, 1.58.14.1, 1.59.10, and 1.60.4.
How to fix
- metabase metabase1.57.19.1, 1.58.14.1, 1.59.10, 1.60.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| metabase metabase | 1.57.0 ≤ v < 1.57.19.1, 1.58.0 ≤ v < 1.58.14.1, 1.59.0 ≤ v < 1.59.10, 1.60.0 ≤ v < 1.60.4 | 1.57.19.1, 1.58.14.1, 1.59.10, 1.60.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.