CVE-2026-50148

Critical

Description

Metabase is an open-source business intelligence and embedded analytics tool. From 1.54.0 until 1.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10, and 1.60.4, a Metabase user with permission to add or edit a database connection can achieve remote code execution on the Metabase server by configuring a Snowflake connection to an attacker-controlled server, because a flaw in the Snowflake JDBC driver can write arbitrary files anywhere on the Metabase host, including replacing one of Metabase's own database driver files that later executes inside the Metabase process. This issue is fixed in versions 1.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10, and 1.60.4.

SeverityCritical
CVSS10.0
Exploit probability—
ProductMetabase
PublishedJul 15, 2026
First seenJul 15, 2026
Weakness typeCWE-73CWE-73

How to fix

Update
  • metabase metabase1.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10, 1.60.4 or later

Affected products

ProductAffected versionsFixed in
metabase metabase1.54.0 ≤ v < 1.54.24, 1.55.0 ≤ v < 1.55.24, 1.56.0 ≤ v < 1.56.25, 1.57.0 ≤ v < 1.57.19, 1.58.0 ≤ v < 1.58.14, 1.59.0 ≤ v < 1.59.10, 1.60.0 ≤ v < 1.60.41.54.24, 1.55.24, 1.56.25, 1.57.19, 1.58.14, 1.59.10, 1.60.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-50148 · Metabase · Dark Radar