CVE-2026-50223

High

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz allows a low-privileged authenticated user with Content/DataResource editing privileges to perform template injection attacks that could lead to Remote Code Execution. This issue affects Apache OFBiz: before 24.09.07. Users are recommended to upgrade to version 24.09.07, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability52. percentile0.7%
ProductApache Ofbiz
PublishedJun 10, 2026
First seenJun 10, 2026

How to fix

Update
  • apache ofbiz24.09.07 or later

Affected products

ProductAffected versionsFixed in
apache ofbizv < 24.09.0724.09.07

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.