CVE-2026-5038
Description
Impact: multer versions 2.0.0-alpha.1 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service when using diskStorage. Aborted or malformed multipart uploads leave orphaned partial files on disk because the Readable.pipe() call does not propagate the stream destroy signal to the underlying fs.WriteStream. An attacker can exhaust disk space by triggering many aborted uploads, with no application bug required. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease). Both versions track in-flight write streams and clean them up on the abort path. Workarounds: None.
How to fix
- expressjs multer2.2.0 or later
- multer2.2.0, 3.0.0-alpha.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| expressjs multer | 2.0.0 ≤ v < 2.2.0, 3.0.0 | 2.2.0 |
| multernpm | 2.0.0-alpha.1 ≤ v < 2.2.0, 3.0.0-alpha.1 ≤ v < 3.0.0-alpha.2 | 2.2.0, 3.0.0-alpha.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.