CVE-2026-50632
High
Description
A further incomplete fix for a previous advisory CVE-2026-44417 (Untrusted JMS configuration can lead to RCE) for Apache CXF has been identified, which can allow code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
SeverityHigh
CVSS8.1
Exploit probability—
Product
Apache Cxf
PublishedJun 12, 2026
First seenJun 12, 2026
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache cxf4.1.7, 4.2.2, 3.6.12 or later
- org.apache.cxf:cxf-rt-transports-jms4.2.2, 4.1.7, 3.6.12 or later
- redhat build_of_apache_camel4.18.1 or later
- redhat jboss_enterprise_application_platform8.1.8 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cxf | v < 4.1.7, 4.2.0 ≤ v < 4.2.2, v < 3.6.12, 4.0.0 ≤ v < 4.1.7 | 4.1.7, 4.2.2, 3.6.12 |
| org.apache.cxf:cxf-rt-transports-jmsMaven | 4.2.0 ≤ v < 4.2.2, 4.1.0 ≤ v < 4.1.7, v < 3.6.12 | 4.2.2, 4.1.7, 3.6.12 |
| redhat build_of_apache_camel | v < 4.18.1, 4.18.1 | 4.18.1 |
| redhat fuse | 7.0.0 | — |
| redhat jboss_enterprise_application_platform | 7.0, 8.1 ≤ v < 8.1.8 | 8.1.8 |
| redhat single_sign-on | 7.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.