CVE-2026-53404

High

Description

Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Tomcat
PublishedJun 29, 2026
First seenJun 29, 2026
Weakness typeCWE-670CWE-670

How to fix

Update
  • apache tomcat9.0.119, 10.1.56, 11.0.23 or later
  • org.apache.tomcat.embed:tomcat-embed-core11.0.23, 10.1.56, 9.0.119 or later
  • org.apache.tomcat:tomcat11.0.23, 10.1.56, 9.0.119 or later
  • org.apache.tomcat:tomcat-catalina11.0.23, 10.1.56, 9.0.119 or later

Affected products

ProductAffected versionsFixed in
apache tomcat8.5.0 ≤ v ≤ 8.5.100, 9.0.0 ≤ v < 9.0.119, 10.1.0 ≤ v < 10.1.56, 11.0.0 ≤ v < 11.0.239.0.119, 10.1.56, 11.0.23
org.apache.tomcat.embed:tomcat-embed-coreMaven11.0.0-M1 ≤ v < 11.0.23, 10.1.0-M1 ≤ v < 10.1.56, 9.0.0.M1 ≤ v < 9.0.119, 8.5.0 ≤ v ≤ 8.5.10011.0.23, 10.1.56, 9.0.119
org.apache.tomcat:tomcatMaven11.0.0-M1 ≤ v < 11.0.23, 10.1.0-M1 ≤ v < 10.1.56, 9.0.0.M1 ≤ v < 9.0.119, 8.5.0 ≤ v ≤ 8.5.10011.0.23, 10.1.56, 9.0.119
org.apache.tomcat:tomcat-catalinaMaven11.0.0-M1 ≤ v < 11.0.23, 10.1.0-M1 ≤ v < 10.1.56, 9.0.0.M1 ≤ v < 9.0.119, 8.5.0 ≤ v ≤ 8.5.10011.0.23, 10.1.56, 9.0.119

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.