CVE-2026-53488

High

Description

containerd is an open-source container runtime. In versions prior to 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10 the CRI plugin propagates labels from an image config (LABEL instruction in Dockerfile) to a container without validation. This may result in executing an arbitrary command on the host, via a plugin that consumes container labels for some operations. This issue has been fixed in versions 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10.

SeverityHigh
CVSS8.8
Exploit probability—
ProductLinuxfoundation Containerd
PublishedJul 1, 2026
First seenJul 1, 2026

How to fix

Update
  • linuxfoundation containerd1.7.33, 2.0.10, 2.1.9, 2.2.5, 2.3.2 or later
  • github.com/containerd/containerd1.7.33 or later
  • github.com/containerd/containerd/v22.0.10, 2.1.9, 2.2.5, 2.3.2 or later

Affected products

ProductAffected versionsFixed in
linuxfoundation containerd1.7.0 ≤ v < 1.7.33, 2.0.0 ≤ v < 2.0.10, 2.1.0 ≤ v < 2.1.9, 2.2.0 ≤ v < 2.2.5, 2.3.0 ≤ v < 2.3.21.7.33, 2.0.10, 2.1.9, 2.2.5, 2.3.2
github.com/containerd/containerdGo1.7.0 ≤ v < 1.7.331.7.33
github.com/containerd/containerd/v2Go2.0.0 ≤ v < 2.0.10, 2.1.0 ≤ v < 2.1.9, 2.2.0 ≤ v < 2.2.5, 2.3.0 ≤ v < 2.3.22.0.10, 2.1.9, 2.2.5, 2.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.